系统要求

我们在 Elementor 的主要目标是为 WordPress 创建最快、最先进的网站构建器。 
为实现这一目标,我们确保它基于可用的最新技术。

以下是使用 Elementor 所需的系统要求。
(如果您不确定您的服务器是否支持此功能,请联系您的主机)。

WordPress 5.2 或更高版本 #

Elementor 适用于 WordPress  5.2 或更高版本

PHP 7 或更高版本 #

注意:如果您的站点托管在使用较旧 PHP 的服务器上,您可能会遇到问题。我们建议您联系您的托管服务提供商以升级到最新版本的 PHP

Elementor 也可以与 PHP 5.4+ 一起使用,但这些旧版本已达到正式的生命周期,因此可能会使您的网站面临安全漏洞和错误,并且可能无法始终按预期工作。

MySQL 5.6 或更高版本 #

MySQL 5.6 或更高版本或 MariaDB 10.0 或更高版本

WP 内存限制 #

WP 内存限制为 128 MB 或更大(首选 256 MB 或更高)

注意:这些要求适用于 Elementor。如果您在您的网站上使用其他具有最低要求的插件,例如 WooCommerce,您可能需要将内存增加到 512 MB,以避免加载问题。另请参阅以下文档Elementor Widget Panel Not Loading

浏览器 #

请注意,您必须使用 Chrome、Firefox、Safari 14.1 及更高版本或 Microsoft Edge 79 或更高版本才能 使用 Elementor编辑页面。将无法编辑使用早于版本 79 的 Microsoft Edge 版本,也不能使用任何版本的 Microsoft Internet Explorer 进行编辑。Microsoft 最新版本的 Edge(v. 79 及更高版本,于 2020 年 1 月首次发布)基于 Chromium(与 Google Chrome 相同的基础),因此 Microsoft 的新 Edge 现在完全能够使用 Elementor 编辑页面。当然,您使用 Elementor 构建的页面将按照所有现代浏览器的设计显示。大多数功能将在 IE 中正确显示,但由于 IE 是较旧的浏览器,它无法支持 Elementor 可能用于其某些功能的某些现代 Web 技术。因此,Elementor 不再支持 IE。甚至微软也停止了对 IE 的支持。如果 IE 支持对于您的特定情况仍然至关重要,您可能需要聘请开发人员来添加自定义代码。您可以在以下位置找到专业的 Elementor 开发人员 Elementor 专家 门户。

设备 #

目前无法使用手机和平板电脑进行编辑。您只能在台式计算机上使用 Elementor 编辑页面。

服务器 #

如果您的网站由 WP Engine 托管,您可能需要将 SSL 添加到您的网站以避免保存问题

如果您使用 SiteGround 或 GoDaddy,请确保他们 为您修改服务器的SubstituteMaxLineLength

X-Frame 选项 #

它必须设置为“同源”以避免编辑问题。请让你的主人为你做这件事。

CSP:框架祖先 #

Content-Security-Policy:frame-ancestors ‘none’ 设置会破坏 Elementor Editor,因为它会阻止编辑器预览所需的 <iframe id=”elementor-preview-iframe”>。这应该设置为 Content-Security-Policy: frame-ancestors ‘self’ 以避免编辑问题。请让你的主机服务商为你做这件事。

PHP Z-Lib 扩展 #

最好  在您的服务器上启用PHP Zlib 扩展。如果没有,请让您的主机服务商为您启用此功能。

Powered by BetterDocs

发表评论

您的电子邮箱地址不会被公开。

Scroll to Top